VM0 - The Google Workspace connector is currently not working properly. – Incident details

The Google Workspace connector is currently not working properly.

Resolved
Partial outage 5 %
Started 13 days agoLasted about 1 hour

Affected

Web Page

Operational from 11:48 AM to 1:05 PM

Runner

Operational from 11:48 AM to 1:05 PM

API Service

Operational from 11:48 AM to 1:05 PM

Storage

Operational from 11:48 AM to 1:05 PM

Connector

Partial outage from 11:48 AM to 1:05 PM

Updates
  • Postmortem
    Postmortem

    The problem stems from a recent update where we modified the update rules for the OAuth connector. Our goal was to implement a more proactive refresh mechanism to ensure a valid token is available whenever the system runs.

    However, this new refresh rule introduced a bug specifically related to the Google OAuth refresh process. Because this issue was difficult to replicate within our automated checking procedures, it was unfortunately deployed to the live environment.

    To prevent this from happening again, we are currently working on implementing automated validation for the OAuth connector workflow to ensure these types of issues are caught before release.

  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating
    We are currently investigating this incident.